Wenn-ABfrageN: ZählenWenn SummeWenn MittelWertWenn ...

Es gibt eine Reihe nützlicher Funktionen, in die eine WENN-Abfrage integriert ist.

ZÄHLENWENN

Mit der Funktion ZÄHLENWENN kannst du ermitteln, wie oft ein von dir gesuchter Wert innerhalb einer Liste, einer Tabelle etc. aufscheint. In unserem Beispiel wollen wir herausfinden, wie viele Produkte in der Spalte „Farbe“ mit der Eigenschaft „blau“ gekennzeichnet sind.

Zu diesem Zweck schreibst du in die Zielzelle folgende Formel:

=ZÄHLENWENN(B2:B11;"blau")

Du gibst also dem Programm den Befehl, es soll =ZÄHLENWENN in dem Bereich B2:B11 die Bedingung/das Kriterium "blau" erfüllt ist. Wie immer wird die Formel in Klammern gesetzt; der Abfragebereich und die Bedingung/das Kriterium werden durch ein Semikolon getrennt.

Als Ergebnis bekommst du den Wert „4“ angezeigt, weil exakt vier Stück der aufgelisteten Produkte als „blau“ gekennzeichnet sind.

Als Ergebnis bekommst du den Wert „4“ angezeigt, weil exakt vier Stück der aufgelisteten Produkte als „blau“ gekennzeichnet sind.

Mithilfe der ZÄHLENWENN-Funktion kannst du aber nicht nur nach einem bestimmten (Text-)Wert, sondern auch nach Zahlen(werten) suchen. Bezogen auf unser Beispiel lautet die Frage: „Wie viele Produkte kosten mehr als 30 Euro?“ Dazu wählst du den neuen Bereich in der Spalte „Preis“ aus und änderst entsprechend die Bedingung in „größer als 30“, sprich du ersetzt „blau“ durch „>30“:

=ZÄHLENWENN(D2:D11;">30")

Achtung: Wenn es sich nicht nur um reine Zahlenwerte (also z. B. 33) handelt, muss genau wie beim Wort „blau“ das Kriterium für die Abfrage zwischen Anführungszeichen gesetzt werden: ">30"

Mithilfe der ZÄHLENWENN-Funktion kannst du aber nicht nur nach einem bestimmten (Text-)Wert, sondern auch nach Zahlen(werten) suchen. Bezogen auf unser Beispiel lautet die Frage: „Wie viele Produkte kosten mehr als 30 Euro?“ Dazu wählst du den neuen Bereich in der Spalte „Preis“ aus und änderst entsprechend die Bedingung in „größer als 30“, sprich du ersetzt „blau“ durch „>30“:

=ZÄHLENWENN(D2:D11;">30")

Achtung: Wenn es sich nicht nur um reine Zahlenwerte (also z. B. 33) handelt, muss genau wie beim Wort „blau“ das Kriterium für die Abfrage zwischen Anführungszeichen gesetzt werden: ">30"

Als Ergebnis erhältst du nun den Wert „6“, weil insgesamt sechs Produkte in der Preisspalte D die Bedingung „teurer als 30 Euro“ erfüllen.

Ergänzender Hinweis: Im Video siehst du, wie der Abfragebereich verschoben wird. Eine Änderung dieses Bereichs kannst du entweder per Hand durchführen, indem du innerhalb der Formel die Werte B2:B11 (in unserem Beispiel) in D2:D11 umänderst. Eine weitere und sehr einfache Möglichkeit bei in Relation identischen Abfragebereichen besteht darin, dass du in der Zelle mit der Formel einen Doppelklick ausführst, wodurch der ausgewählte Bereich hervorgehoben bzw. markiert wird. Dann legst du den Mauszeiger exakt auf den Rand dieses ausgewählten Bereiches – sobald du an der richtigen Stelle bist, erscheint ein kleines Kreuz mit vier Pfeilen – und verschiebst den Bereich ganz einfach mit gedrückter Maustaste an die gewünschte Stelle in der Liste bzw. Tabelle.

SUMMEWENN

Mithilfe der Formel SUMMEWENN wird nicht ermittelt, wie oft ein abgefragter Wert auftritt, sondern es werden mehrere Spalten miteinander abgeglichen und die Zahlenwerte sämtlicher Datensätze zusammengerechnet, in denen der gesuchte Wert aufscheint.

Die Frage für das Beispiel in unserem Video lautet: „Wie hoch ist der Gesamtumsatz aller Produkte, die das Kriterium ,blau‘ erfüllen?“

Dazu wählst du zunächst wieder den entsprechenden Bereich (B2:B11) in der Spalte „Farbe“ aus, gibst die Bedingung „blau“ ein und wählst danach den dazugehörigen Abfragebereich (E2:E11) in der Spalte für die Umsätze aus:

=SUMMEWENN(B2:B11;"blau";E2:E11)

Als Ergebnis bekommst du „922“, weil die Summe der Umsätze aus den Zellen E2 (203), E5 (341), E8 (345) und E11 (33) den entsprechenden Betrag ergeben.

MITTELWERTWENN

Möchtest du beispielweise ermitteln, wie viel die blauen Produkte durchschnittlich kosten, so verwendest du die Abfrage für den Mittelwert nach dem gleichen Muster wie bei SUMMEWENN und wählst dieses Mal den dazugehörigen Bereich in der Preisspalte aus:

=MITTELWERTWENN(B2:B11;"blau";D2:D11)

Als Ergebnis erhältst du „27“, weil die Summe aus den vier Preisen in den Zellen D2, D5, D8 und D11 (29 + 31 + 15 + 33 = 108) geteilt durch 4 ebendiesen Wert ergibt. Die blauen Produkte kosten also im Durchschnitt 27 Euro.

ZÄHLENWENNS | SUMMEWENNS | MITTELWERTWENNS

In vielen Fällen aus dem Alltag kommt es nicht nur darauf an, etwas zu ermitteln, das lediglich eine einzige Bedingung erfüllt, sondern mehrere Bedingungen auf einmal abzufragen, also herauszufinden, welche Datensätze (in unserem Beispiel: welche Produkte) mehrere Kriterien gleichzeitig erfüllen.

Zu diesem Zweck verwendest du die gleichen drei Funktionen wie oben – mit dem einen Unterschied, dass du an die Formelwortlaute vor der öffnenden Klammer jeweils ein S anhängst.

Die Frage in unserem ersten Beispiel lautet: „Wie viele Produkte der Kategorie A sind blau?“

=ZÄHLENWENNS(A2:A11;"A";B2:B11;"blau")

Das entsprechende Ergebnis ist „2“, weil nur auf die beiden Produkte in Zeile 2 und in Zeile 11 die Kriterien „A“ und „blau“ gleichzeitig zutreffen.

Die Beispiele für SUMMEWENNS und MITTELWERTWENNS werden dir Schritt für Schritt im Video erklärt.

Achtung: Im Gegensatz zu SUMMEWENN und MITTELWERTWENN darfst du hier jenen Bereich, für den du die Summe bzw. den Mittelwert errechnen möchtest, nicht an das Ende der Formel (vor die schließende Klammer) stellen, sondern musst diesen als Allererstes gleich nach der öffnenden Klammer anführen; erst danach folgen die Bedingungen/Kriterien für deine Abfrage:

=SUMMEWENNS(E2:E11;A2:A11;"A";B2:B11;"blau")

=MITTELWERTWENNS(E2:E11;A2:A11;"A";B2:B11;"blau")

Ergänzender Hinweis: Während im Video in beiden Fällen die Umsatzzahlen ausgewählt wurden, muss natürlich analog zum Beispiel MITTELWERTWENN, in dem der Durchschnittswert für die Preise von blauen Produkten abgefragt wurde, auch hier bei der Formel MITTELWERTWENNS die Preisspalte ausgewählt werden. Die entsprechende Formel lautet somit:

=MITTELWERTWENNS(D2:D11;A2:A11;"A";B2:B11;"blau")

Das Ergebnis für den durchschnittlichen Preis ist in diesem Fall „31“ (29 + 33 = 62 : 2 = 31).

MINWENNS | MAXWENNS

Mithilfe dieser beiden Formeln lässt sich herausfinden, welche Datensätze (in unserem Beispiel wiederum: welche Produkte), die eine Anzahl von gewissen Bedingungen/Kriterien erfüllen, in einem bestimmten Bereich (z. B. Umsätze etc.) einen Minimalwert bzw. einen Maximalwert aufweisen.

Die beiden Fragen für die Beispiele, die du im Video Schritt für Schritt mitverfolgen kannst, lauten somit:

  1. Minimalwert: „Welcher Umsatz ist der niedrigste innerhalb der grünen Produkte?“
    =MINWENNS(E2:E11;B2:B11;"grün")
    Ergebnis: 960
  2. Maximalwert: „Welcher Preis ist der höchste innerhalb der Produkte der Kategorie ,A‘?“
    =MAXWENNS(D2:D11;B2:B11;"A")
    Ergebnis: 48

In beiden Fällen wurde jeweils nur eine einzige Bedingung in die Formel eingegeben. Genau wie oben kannst du aber selbstverständlich auch hier mehrere Kriterien für eine Abfrage festlegen.

Möchtest du beispielsweise herausfinden, welcher Umsatz von grünen Produkten, die 35 Euro oder weniger kosten, am niedrigsten bzw. am höchsten war, musst du jeweils eine der beiden folgenden Formeln eingeben:

=MINWENNS(E2:E11;B2:B11;"grün";D2:D11;"<=35")

=MAXWENNS(E2:E11;B2:B11;"grün";D2:D11;"<=35")

More...

Zurück zu den Excel Funktionen »