EXCEL WENNFEHLER FUNKTION 

Mit der WENNFEHLER-Funktion kannst du Fehlermeldungen Excel abfangen und stattdessen den Rückgabewert selbst bestimmen. Zum Beispiel bei der SVERWEIS-Funktion kannst du anstatt #NV (nicht verfügbar) auch den Text "Nicht gefunden!" oder die Zahl 0 auswerfen lassen. 

In unserem Beispiel stehen in der Zeile die beiden Werte 10 und 2, die mithilfe der Formel =A2/B2 dividiert werden. Als Ergebnis bekommt man 5. 

Steht allerdings bei gleicher Formel (=A3/B3) in der Spalte B eine Null … 

… so führt dies zu einer Fehlermeldung (hier #DIV/0), weil eine Zahl nicht durch 0 dividiert werden kann. 

Solche Fehlermeldungen haben leider zur Folge, dass auch in anderen Zellen, in denen sich eine Formel befindet, die auf die betreffende Zelle mit der Fehlermeldung zugreift – in unserem Fall die Summenformel =SUMME(C2:C3) in der Zelle C4 –, kein Ergebnis ausgeworfen werden kann. Es wird also ebenfalls eine entsprechende Fehlermeldung angezeigt, weil beispielsweise die Excel SUMMEN-Funktion ausschließlich Werte für eine korrekte Berechnung zulässt. 

Stehen nun wie in unserem Beispiel mehrere Formeln oder Berechnungen untereinander und befindet sich irgendwo mittendrin eine Division durch 0, dann möchte man natürlich nicht, dass dieser Umstand unerwünschte Auswirkungen auf weitere Formeln hat, die auf diese Zelle zugreifen. 

Hier wirkt sich die Fehlermeldung #DIV/0 von Zelle C3 also auf die Summenformel =SUMME(C2:C8) in Zelle C10 aus. 

Sollten nun eventuell weitere Zellen auf diese Zelle C10 zugreifen, dann würde bei allen ebenfalls eine Fehlermeldung ausgeworfen werden. 

Um dieses Problem zu umgehen, bringst du die WENNFEHLER-Funktion ins Spiel. Mithilfe dieser Funktion bestimmst du, dass für den Fall, dass ein Fehler bei der Berechnung auftritt, etwas anderes angezeigt werden soll. 

Du kannst mit der WENNFEHLER-Funktion beispielsweise verfügen, dass anstelle der Fehlermeldung #DIV/0 in der betreffenden Zelle der Wert „0“ angezeigt wird … 

=WENNFEHLER(A3/B3;0) 

… dass die Zelle überhaupt leer bleibt … 

=WENNFEHLER(A3/B3;"") 

… oder dass in der Zelle ein bestimmter Text angezeigt wird. 

=WENNFEHLER(A3/B3;"hier gibt es einen Fehler") 

Wie das funktioniert, kannst du dir noch einmal ganz genau im Video [1:30–2:31 min] ansehen. 

Die Verwendung der WENNFEHLER-Funktion ist bei allen möglichen Arten von Berechnungen sehr zu empfehlen.