Anzahl Übereinstimmungen zählen

Überblick

Um in Excel die Anzahl von Übereinstimmungen von zwei Bereichen zu zählen, kommt die ZÄHLENWENN-Funktion zum Einsatz. Hier in dem Beispiel wollen wir einmal die Übereinstimmungen auf gleicher Zeile und einmal all Übereinstimmungen zählen.

Übereinstimmungen auf gleicher Zeile

=SUMME(--(A4:A10=C4:C10))

Zuerst wollen wir nur die Übereinstimmungen auf gleicher Zeile zählen. Hierfür vergleichen wir die beiden Bereiche A4:A10 und C4:10. Dabei bekommen wir als Ergebnis WAHR und FALSCH als Wahrheitswerte zurück. Das Ergebnisfeld (Array) im Beispiel sieht wie folgt aus  {WAHR;WAHR;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH} 

In Excel werden WAHR als 1 und FALSCH als 0 dargestellt. Daher können wie jetzt die Summe des Ergebnisfeldes berechnen. Damit jedoch die nächste Funktion die Wahrheitswerte als Zahlen erkennt, müssen diese in noch mit einem doppelten Minuszeichen von Wahrheitswerten in binäre Werte also 0 und 1 umgewandelt werden.

Übereinstimmungen gesamt

=SUMME(ZÄHLENWENN(A4:A10;C4:C8))

Um alle Übereinstimmungen zu zählen, kommt die ZÄHLENWENN-Funktion zum Einsatz. ZÄHLENWENN(Bereich; Suchkriterien)

Hier geben wir als Suchkriterien nicht nur einen Wert, sondern alle Werte aus dem 2. Bereich ein. Das führt dazu, dass die ZÄHLENWENN-Funktion mehrfach durchgeführt wird und ein Ergebnisfeld (Array) produziert. Das Ergebnisfeld (Array) im Beispiel sieht wie folgt aus {1;1;1;0;1}

Dieses Ergebnisfeld müssen wir abschließend dann lediglich noch aufsummieren.