WEnn Zelle nicht leer ist dann

Überblick

Um zu prüfen, ob ein Zelle nicht leer ist, benötigen wir die WENN Funktion, sowie zwei Anführungszeichen und Vergleichsoperatoren.

Formel

=WENN(A4<>"";"Ok";"Vorname eintragen")

Funktionsweise der Formel

Um zu prüfen, ob eine Zelle nicht leer ist, müssen wir schauen, ob diese ungleich zwei Anführungszeichen (<>"") ist. Die doppelten Anführungszeichen ("") kann man auch als Leerstring bzw. eine Zeichenkette mit der Länge 0 bezeichnen. Das Kleiner-als-Zeichen (<) und Größer-als-Zeichen (>) ergeben zusammen den Ungleich-Operator (<>). Man kann sich dies auch wie folgt merken: 

Wenn etwas kleiner (<) oder größer (>) ist, kann es nicht gleich (=) sein.
Wenn etwas kleiner (<) oder größer (>) als leer ("") ist, dann ist es nicht leer.

Wenn in der Zelle also nichts drin ist, entspricht dies einem String der Länge 0 und somit ist der Ausdruck aus dem Beispiel in A4<>"" gleich WAHR und in A6<>"" gleich FLASCH.

Wenn sich in der Zelle Leerzeichen oder unsichtbare Zeichen wie z.B. ein Zeilenumbruch befinden, ist diese nicht mehr leer.