Excel SUCHEN Funktion

Überblick

Mit der Excel SUCHEN Funktion kannst du die Position (als eine Zahl) einer Textzeichenfolge in einer anderen Textzeichenfolge ermitteln. SUCHEN gibt die Position des ersten Zeichens von Suchtext innerhalb des Textes wieder. Im Gegensatz zu FINDEN erlaubt SUCHEN Wildcards und unterscheidet nicht zwischen Groß- und Kleinschreibung.

Verwendungszweck / Rückgabewert

Finde die Stelle an der sich eine Zeichenfolge in einem Text befindet

Syntax

=SUCHEN(Suchtext; Text; [Erstes_Zeichen)]

Argumente

Suchtext - Der zu suchende Text (beliebige Zeichenkombination). Hier kann auch ein Array mit mehreren Suchtexten {"a";"b";...} oder ein Verweis auf mehrere Zellen verwendet werden. Dies hat jedoch zur Folge, dass ein Ergebnisarray mit mehreren Einträgen zurückgegeben wird.
Text - Der Text indem gesucht werden soll. 
Erstes_Zeichen - [optional] Die Startposition im zu suchenden Text. Standardwert ist 1.

Beispiele für SUCHEN

Kombinationsmöglichkeiten

1) ISTZAHL+SUCHEN
 =ISTZAHL(SUCHEN(Suchtext; Text; [Erstes_Zeichen)])
In Kombination mit der ISTZAHL-Funktion, kann geprüft werden ob ein bestimmte Zeichenkombination in einer Zelle vorkommt. Da es sich bei dem Ergebnis der SUCHEN-Funktion um eine Positionsangabe handelt, können wir mit der ISTZAHL-Funktion dieses in einen WAHR oder FALSCH Wert umwandeln. Zusammenfassend können wir uns die Funktionsweise auch als "enthält" merken.

2) WENN+ISTZAHL+SUCHEN
=WENN(ISTZAHL(SUCHEN(Suchtext; Text; [Erstes_Zeichen)]);"enthalten";"nicht enthalten")
Wenn wir noch die WENN-Funktion hinzunehmen, können wir uns folgende Konstruktion bauen:
wenn Zelle x enthält dann y sonst z

3) ANZAHL+SUCHEN+Array mit mehreren Suchtexten
=ANZAHL(SUCHEN({"a";"b"};A1))
Hier wird nach dem Buchstaben "a" und "b" gesucht. Im Ergebnis erhalten wir 2 Ergebniszellen, die entweder die Position des Suchtextes oder bei Nichtvorhandensein dem #WERT! Fehler ausgeben. Mit ANZAHL können wir zählen wie viele dieser Zellen eine Zahl enthalten.

Dies ermöglicht uns folgende Bedingungen z.B. für eine WENN-Funktion zu formulieren:
wenn mind. 1 Suchkriterium enthalten  ANZAHL(SUCHEN({"a";"b"};A1))>0
wenn mehr als 1 Suchkriterium enthalten ANZAHL(SUCHEN({"a";"b"};A1))>1
wenn genau 2 Suchkriterien enthalten ANZAHL(SUCHEN({"a";"b"};A1))=2

Beispiele dafür findest Du hier:
https://excelhero.de/formeln/wenn-zelle-x-enthaelt-dann/

Zu beachten

  • Verwende die Funktion SUCHEN, um die Position einer Textzeichenfolge in einer anderen zu ermitteln.
  • Im Gegensatz zu FINDEN erlaubt SUCHEN die Verwendung von Platzhaltern und unterscheidet nicht zwischen Groß- und Kleinschreibung. 
  • SUCHEN ermöglicht die Platzhalterzeichen Fragezeichen (?) Und Sternchen (*) im Suchtext.
  • Das ? dient als Platzhalter für ein einzelnes Zeichen und das * für eine beliebige Zeichenfolge. Beispiel: „Hall?“ würde „Hallo“ und „Halle“ finden. „Guten*“ würde „Guten Tag“ finden.
  • Um das Fragezeichen oder Sternchen selber zu finden, musst du eine Tilde (~) vor dem Zeichen, also ~ * und ~ ? verwenden.