Wenn Funktion bei Excel

1) Wenn-Funktion: Beispiel Ampel

Die WENN-Funktion bzw. die WENN/DANN-Funktion ist eine sehr häufig verwendete Excel Funktion, bei der du eine Abfrage erstellst, indem du eine Bedingung (oder auch mehrere Bedingungen gleichzeitig) festlegst, um ein entsprechendes Ergebnis zu erhalten, falls diese Bedingung(en) erfüllt ist (bzw. sind). Wird (bzw. werden) diese Bedingung(en) nicht erfüllt, wird dir ein anderes Ergebnis ausgeworfen.

Das mag vielleicht im ersten Moment ein wenig kompliziert klingen, ist aber im Grunde genommen sehr einfach.

Bevor du eine WENN/DANN-Bedingung mittels Excel-Formel erstellen kannst, musst du zuerst eine logische Prüfung formulieren. Du musst also eine spezifische Bedingung stellen, die entweder erfüllt werden kann oder nicht. Je nachdem also, ob die Antwort auf deine Frage WAHR oder FALSCH ist, führt dies entweder zu dem einen oder zu einem anderen Ergebnis.

Einfacher ausgedrückt: WENN eine bestimmte Bedingung erfüllt wird, DANN wird ein entsprechender Wert herausgegeben. WENN diese Bedingung hingegen NICHT erfüllt wird, DANN wird ein alternativer Wert ausgeworfen.

In unserem Ampel-Beispiel im Video lautet die WENN/DANN-Bedingung:

„WENN die Ampel auf Rot steht, DANN möchte ich stoppen. WENN die Ampel auf Grün springt, DANN möchte ich losfahren.“

Excel-Wenn-Funktionen-Ampel1

Hier noch einmal die einzelnen Schritte im Detail, wie du zu der oben angeführten WENN/DANN-Formel in C3 gelangst:

  1. Schritt – Formulierung der Anfangsbedingung: „WENN die Ampel auf Rot steht, DANN möchte ich stoppen.“ Diese Bedingung – die Ampel ist rot – kann wahr oder falsch sein.
  2.  Schritt – Formulierung der Alternativbedingung für den Fall, dass die Anfangsbedingung nicht erfüllt wird: „WENN die Ampel auf Grün springt, DANN möchte ich losfahren.“

    (Bitte beachte: Diese beiden Bedingungen kannst du hier nur deshalb so formulieren, weil du in diesem Beispiel lediglich zwei Optionen – rote Ampel und grüne Ampel – zur Verfügung hast, für die es wiederum nur zwei Optionen – stoppen oder losfahren – gibt. Wie du Bedingungen für mehrere Optionen erstellst, erfährst du in diesem Artikel.)
  3. Schritt – Bestimmung der Zelle, auf deren Inhalt sich die Abfrage der oben formulierten Bedingung („Die Ampel ist rot“) bezieht: B3
  4. Schritt – Erstellung der Formel: =WENN(B3="Rot";"stoppen";"losfahren")
    In Worten ausgedrückt: =WENN( in der Zelle B3 die Bedingung ="Rot" erfüllt ist; DANN werde ich "stoppen"; SONST werde ich "losfahren").

Zeichensetzung: Die Bedingung ("Rot") und die beiden Alternativen ("stoppen" bzw. "losfahren") werden unter Anführungszeichen gesetzt. Zwischen der Bedingung (WENN), der Option 1 (DANN) und der Alternativoption (SONST) wird jeweils ein Strichpunkt eingefügt.

B3 erfüllt in unserem Beispiel die Bedingung der Abfrage – ist also WAHR –, daher wird in der Zelle C3 als Ergebnis der erste DANN-Wert „stoppen“ ausgeworfen.

Dies kannst du auch überprüfen, indem du in der Zelle die Bedingung B3="Rot" markierst. 

Excel-Wenn-Funktionen-Ampel2

Wenn du anschließend auf F9 drückst, ändert sich die Bedingung innerhalb der Formel zu WAHR.

Excel-Wenn-Funktionen-Ampel3

Noch einmal das Ganze mit anderen Worten: Ist der WENN-Wert wahr, d. h., ist die Bedingung erfüllt und entspricht der abgefragte Wert „Rot“ dem Inhalt in der abgefragten Zelle B3, dann wird als Ergebnis der nächstliegende DANN-Wert „stoppen“ ausgeworfen.

Wenn du nun die Formel von C3 in die Zelle C4 hineinkopierst, wird analog zu oben abgefragt, welcher Wert sich in der Zelle B4 befindet.

Excel-Wenn-Funktionen-Ampel5

In diesem Fall entspricht der Wert in der abgefragten Zelle B4 NICHT der Bedingung „Rot“, das heißt, die Anfangsbedingung wird nicht erfüllt, ist also FALSCH. Auch das kannst du wiederum nachprüfen, indem du genau wie oben B4="Rot" markierst und anschließend auf F9 drückst.

Excel-Wenn-Funktionen-Ampel5

Der Inhalt von B4 ist „Grün“. Aus diesem Grund wird der erste DANN-Wert („stoppen“) übersprungen und der SONST-Wert – sprich der alternative DANN-Wert „losfahren“ – in der Zelle C4 wiedergegeben.

Excel-Wenn-Funktionen-Ampel6

Diese Abfrage lässt sich selbstverständlich auch mit Zahlenwerten durchführen und wird dir im Video ab 2:51 min im Detail erklärt.

2) Wenn-Funktion: Beispiel mit Zahlenwerten

In diesem Bonus-Beispiel lautet die WENN/DANN-Bedingung:

„WENN ein Mitarbeiter mehr als € 4.000,– Umsatz generiert, DANN erhält er einen Bonus. WENN ein Mitarbeiter weniger als € 4.000,– Umsatz generiert, DANN erhält er keinen Bonus.“

Die dazugehörige Formel für Zelle G3 lautet also:
=WENN(F3>4000;"Bonus";"kein Bonus")

Excel-Wenn-Funktionen-Mit-Zahlenwerten1

Auch hier die Formel =WENN(F3>4000;"Bonus";"kein Bonus") noch einmal in Worten ausgedrückt:

=WENN( in der Zelle F3 die Bedingung >4000 erfüllt ist; DANN erhält der Mitarbeiter einen "Bonus"; SONST wird dem Mitarbeiter "kein Bonus") ausbezahlt.

Nachdem du die Formel in alle dazugehörigen Zellen eingefügt hast, erhältst du folgendes Ergebnis:

Excel-Wenn-Funktionen-Mit-Zahlenwerten2

Die Mitarbeiter A und B haben einen Umsatz unter € 4.000,– erzielt, somit wird ihnen „kein Bonus“ ausbezahlt. Mitarbeiter C hat einen Umsatz von € 5.000,– erreicht und erhält einen „Bonus“.

Es müssen aber nicht immer für beide Optionen auch tatsächlich konkrete Werte ausgeworfen werden. In vielen Listen und Tabellen lassen sich die Ergebnisse einer Abfrage beispielsweise durch leere Zelle optisch bei Weitem besser und schneller erfassen.

Hierbei kannst du für den Fall, dass die Anfangsbedingung nicht erfüllt wurde, die entsprechende Zelle leer lassen, indem du in der Formel als SONST-Option ein (oder zwei) Leerzeichen zwischen die Anführungszeichen setzt.

3) Wenn-Funktion: Beispiel Prüfungsergebnisse

Die WENN/DANN-Bedingung im folgenden Beispiel (nicht im Video angeführt) lautet:

„WENN ein/-e Prüfungskandidat/-in 80 % oder mehr der Testfragen beantworten konnte, DANN hat er/sie die Prüfung bestanden. WENN ein/-e Prüfungskandidat/-in weniger als 80 % der Testfragen beantworten konnte, DANN hat er/sie die Prüfung nicht bestanden.“ 

Excel-Wenn-Funktionen-Prüfung1

Das Resultat, nachdem die Formel in alle Zellen der Ergebnis-Spalte übertragen wurde:

Excel-Wenn-Funktionen-Prüfung2

4) Verschachtelte WENN-Funktion

In den vorhergegangenen Beispielen hast du nur eine einzige Prüfung innerhalb der WENN-Funktion vorgenommen, das heißt, du hast nur eine einzige Bedingung gestellt, deren Abfrageergebnis entweder WAHR oder FALSCH sein konnte. Selbstverständlich kannst du die WENN-Funktion aber auch mehrfach innerhalb einer einzigen Formel verwenden, sprich mehrere Bedingungen gleichzeitig stellen und diese miteinander verschachteln.

In unserem Beispiel haben wir die Ampelfarben um die Farbe Orange erweitert.

Dein Ziel: Du möchtest das Auto stoppen, wenn die Ampel entweder auf Rot oder auf Orange steht. Daraus ergibt sich also eine zusätzliche Option für dich, und du musst nun in jeder Zeile überprüfen, ob eine dieser beiden Bedingungen – 1) die Ampel steht auf Rot oder 2) die Ampel steht auf Orange – erfüllt wird, also WAHR ist. Dies geschieht, indem du die eine WENN-Funktion mit der anderen WENN-Funktion verschachtelst.

In unserem Beispiel bedeutet „verschachteln“, dass die beiden Bedingungen unmittelbar hintereinander mittels WENN-Funktion abgefragt werden, wobei auch hier die Trennung innerhalb der Formel wiederum durch einen Strichpunkt erfolgt.

Deine neue Formel lautet somit:
=WENN(B3="Rot";"stoppen";WENN(B3="Orange";"stoppen";"fahren"))

Auch hier diese Verschachtelung zur besseren Veranschaulichung in Worten ausgedrückt:

=WENN( in der Zelle B3 die 1. Bedingung ="Rot" erfüllt ist; DANN werde ich "stoppen"; ist dies nicht der Fall, DANN werde ich, =WENN( in der Zelle B3 die 2. Bedingung ="Orange" erfüllt ist; "stoppen"; SONST werde ich "fahren").

WICHTIG: Bei derartigen Verschachtelungen treten innerhalb der Formeln mehrere Klammern auf. Achte darauf, dass der Anzahl der geöffneten Klammern ebenso viele geschlossene Klammern gegenüberstehen. Solltest du einmal eine oder mehrere Klammern vergessen, erhältst du eine entsprechende Fehlermeldung.

In vielen Fällen – wie auch in unserem Beispiel – wird dir übrigens das Excel-Programm einen Lösungsvorschlag für die Behebung solcher Unstimmigkeiten anbieten.

Sobald du die eingegebene Formel (beispielsweise durch Ziehen) in die beiden Zellen darunter überträgst, bekommst du das entsprechende Ergebnis ausgeworfen.

Ergänzender Hinweis: Vielleicht ist dir aufgefallen, dass in den Screenshots die Farbenbezeichnungen „rot“ sowie „orange“ innerhalb der Formel kleingeschrieben sind, während hier im Text dieses Artikels die beiden Farben „Rot“ und „Orange“ innerhalb der Formel jeweils mit einem großen Anfangsbuchstaben geschrieben wurden. Für das Ergebnis ist es nicht wichtig, ob du die Groß- und Kleinschreibung beachtest (du könntest zum Beispiel auch „oRaNgE“ schreiben, und das Ergebnis wäre trotzdem korrekt). Sehr wohl entscheidend sind jedoch die richtigen Buchstaben bzw. die korrekte Buchstabenfolge.

Würdest du dich also in der Formel verschreiben und anstelle von „orange“ bzw. „Orange“ beispielsweise „oranfe“ oder „Oragne“ schreiben, …

… dann würde zwar in der ersten Zeile wie bisher als Ergebnis „stoppen“ stehen, weil ja die erste Bedingung „Rot“ erfüllt ist. Allerdings würde in diesem Fall auch in der zweiten Zeile – genau wie bei „Grün“ in der Zeile darunter – der Wert „fahren“ ausgeworfen werden, weil die korrekte Schreibweise in B4 („Orange“) und die falsche innerhalb der Formel („Oragne“) aufgrund des Buchstabendrehers nicht übereinstimmen und somit die zweite Bedingung nicht erfüllt ist.

Wie du innerhalb einer verschachtelten Funktion mithilfe der F9-Taste abfragen kannst, ob die beiden Bedingungen erfüllt wurden oder nicht – ob sie also WAHR oder FALSCH sind –, wird dir im Video ab 2:12 min gezeigt.

Diese Abfrage mit F9 ist auch gleichzeitig eine Methode, um Fehler innerhalb der Formel herauszufinden, wenn offensichtlich ein falsches Ergebnis – in unserem Beispiel „fahren“ anstelle von „stoppen“ in der Zeile für „Orange“ – ausgeworfen wurde.

Während in der ersten Zeile „Rot“ steht und somit (unabhängig von der falschen Schreibweise „Oragne“) die Taste F9 für die zweite Bedingung den Wert FALSCH auswirft, bekommst du auch in der zweiten Zeile aufgrund ebendieses Schreibfehlers/Buchstabendrehers das Ergebnis FALSCH angezeigt, obwohl du eigentlich WAHR erwarten würdest.

Der Fehler kann sich also entweder in der Zelle, auf die sich die Formel bezieht, oder in der Formel befinden, denn du könntest dich ja in einem umgekehrten Fall genauso gut nicht in der Formel selbst, sondern in der Bezugszelle verschrieben haben.

Wenn dir diese Einführung gefallen hat und du mehr zum Thema Excel Funktionen lernen möchtest, dann würde ich mich freuen, dich in meinem Kurs: Excel Funktionen: Sverweis und co. meistern wieder begrüßen zu dürfen.